Solaris Package Manager

– pkginfo -l (Anzeige der installierten Packages)
pkgchk -v

pkgadd -R -d (Package installieren)
pkgrm

RedHat Package Manager

rpm -qiget info
rpm -ivhinstall a package
rpm -Uvh rpm -e

upgrade a package
remove a package:

rpm -qlwhich files belong to a package
rpm -qilplook in a rpm filename that isnt installed
will give you a list of all files that have changed in one form or another since the package it is associated was installed.
$ rpm -Va | awk ”{print $2}” | xargs rpm -qf | sort -u &> /tmp/file1

the way to compile a package:

gunzip < file.tar.gz | tar xvf –
./configure to configure the package
make to compile the package.
make check to run any self-tests
make install
to install the programs
make clean
to remove the program binaries

Leave a Reply

Your email address will not be published. Required fields are marked *

*